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Overview
Windows Embedded Standard 7 (WES7) provides the ability to create a customized embedded form of
Windows that includes only those components that are needed by the target system.
Earlier versions of Windows Embedded provided a more granular configuration process that required all
components of the operating system to be selected before an image could be built. This process allowed
IntervalZero to provide RTX Runtime components that could be directly added to a target image. With
Windows Embedded Standard 7, Microsoft simplified the target creation process by changing the way that
individual components are selected. As a result, RTX Runtime components can no longer be directly added
to a target build. Instead, new functionality is available to automatically perform a silent install of RTX
Runtime as WES7 is being installed onto the target system.
With Windows Embedded Standard 7, there are two ways to build an image:
l

l

The Express Path uses the Image Builder Wizard (IBW) to build an image based on the answers to basic
configuration questions.
The Advanced Path uses the Image Configuration Editor (ICE) to create an answer file that defines the
functionality, software and settings that are needed in the image. This is the most flexible way to create
an image and provides the ability to perform an unattended installation of WES7.

This MiniTutorial will focus on the advanced path and walk you through the steps necessary to create a
Windows Embedded Standard 7 image that includes the RTX 2012 Runtime with Update 3.
More information on Windows Embedded Standard 7 can be found by looking at the links provided in the
Resources section at the end of this document.

WES7 Image Creation Steps
Creating an image that includes the RTX Runtime requires the following steps:
l

Install the Windows Embedded Standard 7 Toolkit.

l

Start the Image Configuration Editor.

l

Create an Answer File (AF).

l

Select a Distribution Share (DS).

l

Add the RTX Silent Installer to the Distribution Share.

l

Add the RTX installation command to the Answer File.

l

Add Additional Components to the Image.

l

Analyze Installation Kit Dependencies.
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l

Validate the Answer File.

l

Create Image Files.

l

Create a Bootable Device.

l

Add Image Files to the Device.

l

Boot the WES7 Install on the Target System

l

Customize the Image.

l

Activate RTX. For more information, see the RTX Deployment Guide at
http://www.intervalzero.com/technical-support/guides-and-minitutorials/.
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Install Windows Embedded Standard 7
Toolkit
The instructions in this MiniTutorial assume that the Windows Embedded Standard 7 Toolkit has already
been installed. For information on obtaining the software, visit the Microsoft web page:
Windows Embedded Standard
Installation instructions can be found on the MSDN website at:
Install Windows Embedded Standard 7 Toolkit on a Development Computer

Create Image Using ICE
The Image Configuration Editor (ICE) allows you to create an answer file that will define the components and
settings for your target installation.

Start the Image Configuration Editor:
Once the Windows Embedded Standard 7 Toolkit has been installed, start the Image Configuration Editor
from the Start menu by selecting:
Windows Embedded Standard 7 > Image Configuration Editor

Create an answer file:
To create a new answer file
From the File menu, select New Answer File.
NOTE: The new answer file has a default name of Untitled. To name the file, save the answer file by
selecting Save Answer File from the File menu. For now, ignore validation errors as they will be
corrected later.

Select a distribution share:
All components that will be used to build the image are stored in a distribution share (DS) folder. Using a
shared folder allows the same source to be used to create multiple images. Preconfigured, default
distribution shares include:
l

C:\Program Files\Windows Embedded Standard 7\DS
For a 32-bit distribution built on a 32-bit development computer
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l

C:\Program Files\Windows Embedded Standard 7\DS64
For a 64-bit distribution share built on a 32-bit development computer

Since IntervalZero RTX Runtime supports only the 32-bit version of WES7, to ensure you have the correct
distribution share:
1. Right-click the directory specification under the Distribution Share heading.
2. Click Select Distribution Share from the pop-up menu.
3. Browse to and then double-click:
C:\Program Files\Windows Embedded Standard 7\DS
NOTE: This assumes that Windows Embedded Standard 7 was installed in the default directory.

Add the RTX Runtime Installer to the distribution share:
The distribution share should contain all components needed to build the image. To include RTX Installer in
the image, it must be added to a subdirectory of the distribution share. To do this:
1. Right-click the directory name at the top of the Distribution Share tree.
2. Select Explore Distribution Share... from the pop-up menu.
3. When an explorer window pops up:
a. Browse to (or create, if it does not exist) the following subdirectory in the distribution share
directory tree.
<DS>\$OEM$ Folders\Custom Files\$OEM$\$1
Where the default value of <DS> is C:\Program Files\Windows Embedded Standard
7\DSSP1.
b. Copy the RTX Runtime installer (RTX_2016_Setup.exe) to this subdirectory
NOTE: The \$OEM$\$1 directory represents the root of the drive onto which you will install Windows
Embedded Standard 7.
To ensure files in this $OEM$ directory and subdirectories are included in your image:
1. Right-click the Answer File (name, or "Untitled" if it has not yet been saved).
2. In the pop-up menu, click Insert Oem Folders Path.
3. Browse to <DS>\$OEM$ Folders\Custom Files\$OEM$
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After the command has been added, you can see it by browsing the Answer File pane to
Product\Operating System\Foundation Core\Windows Embedded Edition\Setup_x86,
and then look for PathAndCredentials under OEMFoldersPaths in the Settings pane.
For more information, refer to the MSDN article:
Add Custom Files and Folders Using Image Configuration Editor

Add the RTX installation commands to the answer file:
ICE allows the developer to add custom commands to the answer file. To perform an installation of the RTX
Runtime, add it to the answer file as follows:
1. Right-click the Answer File (name, or Untitled if it has not yet been saved).
2. In the pop-up menu, click Insert Synchronous Command to Pass 7 oobeSystem.
3. Enter the RTX Runtime installation command using the full directory path.
4. Set the Order value to 2
5. Click OK.
As noted above, since the Installer file was copied to the \$OEM$\$1 subdirectory, an example of the
command line would be :
C:\RTX_2016_Setup.exe

For information on installing the RTX Runtime Silently, see the RTX Silent Install Guide.
NOTE:
After the command has been added, you can see it by browsing the Answer File pane to
Product\Operating System\Foundation Core\Windows Embedded Edition\ShellSetup_x86, and then looking for CommandLine under the FirstLogonCommands, Synchronous
Commands in the Settings pane.
After the RTX Runtime install command has run, you must reboot your system for the RTX Runtime
installation to complete.
After the RTX Runtime installation has run, the install kits will still reside in the base directory.You can
optionally add a second synchronous command to remove the file, such as:
cmd /c del "C:\RTX_2016_Setup.exe"
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Add additional components to the image:
A new WES7 answer file begins with the Windows Embedded Edition Foundation Core component.
Additional components are selected by the user. RTX requires both the Windows Installer and the Device
Driver Frameworks.
Follow these instructions to add each component:
1. Expand the Distribution Share to locate the component.
2. Right-click the component.
3. From the pop-up menu, click Add to Answer File.
A new WES7 answer file requires the following components:
l

Packages > FeaturePack >.NET Framework > .NET Framework 2.0 Client Profile

l

Packages > FeaturePack >.NET Framework > .NET Framework 3.0 Client Profile

l

Packages > FeaturePack >.NET Framework > .NET Framework 3.5 Client Profile

l

Packages > FeaturePack > System Services > Windows Installer

l

Packages > FeaturePack > Devices and Printers > Driver Frameworks

l

Packages > FeaturePack > Management > Windows Application Compatibility

l

Packages > FeaturePack > Management > Windows Updates

l

Packages > FeaturePack > Management > System Management > Group Policy Management

l

Packages > FeaturePack > Management > System Management > System Management
Administration

l

Packages > FeaturePack > Management > System Management > System Management Utilities

l

Packages > FeaturePack > Management > Power Management

l

Packages > FeaturePack > Networking > Remote Access Service (RAS) (required for activation over
a network connection)

NOTE: RTX requires .NET 4.5.1 for configuration on Windows 7 systems.
Additional components can be added either by selecting them individually, or by including a template that
contains a common group of features. The WES7 kit provides the ability to use one of several predefined
templates. To view and select one of these, do the following:
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1. Expand the Distribution Share to locate Templates > IBW.
2. Right-click a template.
3. Select Add to Answer File from the pop-up menu.
NOTE: Once you have selected each of the components that you want to include, you can save your
own template to be used as an initial starting point for future image builds.

Analyze installation kit dependencies:
The Image Configuration Editor provides a tool to analyze a silent installer file and determine what
components it depends upon. Analyze the RTX Runtime installation file as follows:
1. From the Tools pull-down menu, select Analyze Static Dependencies.
2. Browse to the RTX_2016_Setup.exe file that was added to your selected distribution share.
3. A pop-up status window will appear while static dependencies are being analyzed.
4. In the Analyze Static Dependencies window
l

Select Required Packages.

l

Enter a name for the file subfolder (such as RtxDependencies).

l

Click OK.

The selected components will now be in the Answer File.

Validate the answer file:
The new answer file will include the Windows Embedded Edition Foundation Core and any additional
components you have added. Some of the components that were added will have required dependencies
and others will allow you to select from a group of optional dependencies. To ensure that all required and
optional dependencies are included,
1. From the Validate menu, select Validate Only.
2. In the Messages Pane at the bottom of the window, double-click each validation description and select
optional and required components from the Resolve Dependencies window.
Repeat the steps above until no more validation errors are displayed.
NOTE: After making any changes to the answer file (such as adding components or importing a
template) you should repeat the validation steps to ensure any dependencies are satisfied and then
save the answer file using File > Save Answer File.
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Create image files:
Once all selections have been made and the Answer File has been saved, create image files that will be
copied to a bootable device. Create the Windows Image Builder Wizard (IBW) files using:
Tools > Create Media > Create IBW Image from Answer File
Select a directory location to store the IBW image files. Remember this directory location, as it will be needed
when the image is put onto a bootable device. For example, C:\temp\IBW_wRTX_Image.
Optional installation procedure: This MiniTutorial walks you through the steps needed
configure a single device that will boot and then automatically begin setup of the WES7 install.
It is also possible to install WES7 after booting from a lightweight or preinstallation
environment (PE) version of Windows. To do that, see the section titled Installing From PE Image
at the end of this document.
Once the image has been saved, you can exit the Image Configuration Editor.
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Put Image Files onto a Bootable Device
To install the new Windows Embedded Standard 7 onto your target, you must first create a bootable device.
The steps needed to create bootable media that will automatically run Setup from the IBW image are listed
below.
1. Create a bootable device (USB flash drive, CD-ROM disk or other bootable media).
2. Copy all files from the IBW image directory to the bootable device.
3. Boot the target system from the newly configured device and setup of the IBW image files will
automatically begin.
Instructions for creating a bootable USB Flash Drive (UFD) and for creating a bootable CD-ROM are given
below. Select one of these, or read the following MSDN article for help with other device options:
Image Builder Wizard – Quick and Easy Embedded OS Creation
NOTE: Instructions are given for creating a bootable UFD and for creating a bootable CD-ROM. Other
media that can be booted on your system can also be used. Only one media type needs to be selected
and created.

Create a bootable UFD with IBW image files:
To create a bootable USB Flash Drive (UFD) open a command prompt with Administrator privileges and use
the diskpart utility as shown below. These instructions can also be found in the MSDN article titled Create a
Bootable Utility UFD.
NOTE: The diskpart utility in Windows XP does not show removable storage in a disk list. So, this
step should be performed using a Windows Vista or Windows 7 system.
1. Start the disk partition tool:
diskpart
2. Determine your disk number:
list disk
3. Select your device
select disk <disk_number>
4. Remove partition and volume information
clean
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5. Create a primary partition
create partition primary
6. Set focus to the newly created primary partition
select partition 1
7. Mark the partition with focus as a valid system partition
active
8. Format the partition
format FS=ntfs LABEL=<Label> QUICK
9. Assign a drive letter to the partition
assign
or
assign LETTER=<L>
10. Exit the diskpart utility
exit
Copy all files from the IBW image directory to the bootable UFD using the following command:
xcopy

C:\temp\IBW_wRTX_Image\*.*

/s

/e

/f

L:\

where C:\temp\IBW_wRTX_Image is your IBW image file directory and L:\ is your UFD drive letter.

Create a bootable CD-ROM with IBW image files:
To create a bootable CD-ROM with IBW image directory files, you must first create an ISO that contains a
bootable image of the IBW directory as follows:
1. From the Start menu on the development computer, select
All Programs > Windows Embedded Standard 7 >
Windows PE Tools Command Prompt
A Windows PE Tools Command Prompt window opens.
2. At the Windows PE Tools command prompt, use the Oscdimg tool to create an ISO file that has the
contents of the image directory you created, using the ETFSBOOT.COM command located in the BOOT
subdirectory. For example, if your image directory is C:\temp\IBW_wRTX_Image and you want to
create your ISO in C:\temp\, called IBW_wRTX.iso type the following:
oscdimg -n -bc:\temp\IBW_wRTX_Image\BOOT\ETFSBOOT.COM C:\temp\IBW_wRTX_Image
C:\temp\IBW_wRTX.iso
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Where parameters to oscdimg are:
-n allow long names
-blocation - Location of boot sector file (no space after the "b")
Location of image source files
Location of target ISO file
The Oscdimg command above will create a bootable ISO file named IBW_wRTX.iso in the c:\temp\ folder.
Using CD-ROM burning software, burn the ISO file to a blank CD-ROM.
For more information, refer to the MSDN article: Create and burn the ISO file to a CD-ROM
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Boot the WES7 Install on the Target
System
The Image Configuration Editor allows you to create an answer file that includes the components and
settings for an image that will be installed onto your target system.
NOTE: When the image created by this MiniTutorial is installed onto the target system, you will be
prompted for basic settings. To configure an answer file to be fully unattended, see the Resources
section at the end of this document.
Before booting your image, check that the system BIOS is set to ensure that the boot order includes the
device that you have built your IBW image onto.
After inserting your boot media, the following should occur:
l

Messages will display indicating:
n

Windows is loading files

n

Starting Windows

n

Setup is Starting

l

License agreement will be displayed. Read and accept terms and click Next.

l

Language preferences will be displayed. Select and click Next.

l

Available disks will be displayed.

l

n

Select the disk for the target installation.

n

To format the disk, expand drive options and select Format.

n

To use the selected disk click Next.

Windows installation messages will appear including:
n

Copying Windows files

n

Expanding Windows files

n

Installing features and updates

The system will reboot to apply system settings. When the system comes back up, the Windows Boot
Manager will include Windows Embedded Standard as a new boot option.
NOTE: If using a bootable UFD, remove it after system files have been copied, and before a reboot
occurs.
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Customize the Image
The first time you start your image, the following setup prompts will appear.
l

Username and Computer name

l

An optional user password

l

Product key

Customization will continue after selecting one of the following:
l

User recommended settings

l

Install important updates only

l

Ask me later

The last prompt will be for time and date settings.
After screens for Welcome and Preparing your desktop the RTX Runtime installation will occur.
n

A Windows Security pop-up window will confirm the installation IntervalZero software. Click Install to
continue.

n

A warning that setup was unable to interface with the power management service may appear. Since RTX
does not use Power Management services, this warning can be ignored. Click OK to continue.

After the installation of RTX, you must reboot your system for the RTX Runtime installation to complete.
IMPORTANT! To confirm that the system has been rebooted after the installation of RTX, go to the
Control tab of the RTX Properties control panel. If status is Undetermined, the system needs to be
rebooted. If status is Stopped you can start the subsystem by clicking the Start button.
To make custom changes to the Windows Image (.wim) file of a target system that has been installed and is
running, use the Deployment Image Servicing and Management (DISM) tool.
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Activate RTX
For instructions on how to activate RTX, see the RTX Deployment Guide at
http://www.intervalzero.com/support/useful-documentation/.
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Installing From PE Image
This MiniTutorial walks you through the steps needed to configure a single device that will boot and then
automatically begin setup of the WES7 installation. It is also possible to install WES7 after booting from a
lightweight, or preinstallation environment (PE) version of Windows. To do this, follow the steps below.
If you do not already have a bootable PE device, do the following.

Steps:
1. Create a PE image from ICE using:
Tools > Create Media > Create Windows PE Image
Select a directory location to store the PE image files, such as C:\temp\PE_Image\
2. Create a bootable device (USB flash drive, CD-ROM disk, etc.).
3. Copy all files from the PE image directory to the bootable device.
4. Boot from the bootable device containing PE image files.

To perform the install:
1. Copy all files from the customized IBW image to other media or to the target machine.
2. After the PE system has booted, run Setup from the IBW image files.
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Resources
For more information, see the following documents:
l

Windows Embedded Standard: Product Overview

l

Windows Embedded Standard 7 Technical Overview

l

Windows Embedded Standard 7 on-line documentation

l

WES7 documentation section on Building Images

l

l

Windows Embedded Standard White Papers link to Architectural Comparison of Windows Embedded
Standard 7 vs. Windows Embedded Standard 2009
Configure an Answer File to be Unattended
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